Commitment to Service Delivery – COVID-19
Incident Report for Pax8
Resolved
This incident has been resolved.
Posted Jul 15, 2020 - 10:06 NZST
Monitoring
Over the past 4 weeks, we have been validating our continuity plans and operational processes in relation to COVID-19 to ensure we continue to maintain our Service Level agreements to you.

Our services organisation was placed into 'remote working' as of March 19th to support the advice from New Zealand Government, and whilst in this mode of working we have continued to deliver to SLA, with no impact to service. Whilst additional physical distancing measures have been announced today (23/3/20), we are not foreseeing any change in the ability for us to maintain our levels of service to you.

As an essential infrastructure utility provider to the country, we will remain open, albeit virtually, to service the infrastructure needs of our partners and customers alike.

Our commitment is to keep you up to date on https://status.umbrellar.com and our official update at https://umbrellar.com/covid-19. Rest assured, we are taking every measure possible to protect New Zealanders both in terms of health, and the services we provide that underpin your technology needs.

If you have any questions relating to the above announcement or your services, please speak to your account manager, email us at help@umbrellar.com
Posted Mar 23, 2020 - 18:08 NZDT
This incident affected: Pandemic Response Plan (Service Operations).