Umbrellar Account Registration Unavailable
Incident Report for Pax8
Resolved
New Umbrellar registrations are back online and available to all again. You will now need to have your new account activated by a member of the Umbrellar Success Team before it is usable within the Umbrellar Portal. You will be contacted by the team shortly after registration, or please contact the team via live chat, help@umbrellar.com or 0800 344 493. Thanks.
Posted Jun 19, 2018 - 16:27 NZST
Identified
New Umbrellar registrations are currently unavailable while we work to fix an identified issue. Registrations will be back online shortly, in the mean time please contact our Success Team on 0800 344 493. Apologies for the inconvenience.
Posted Jun 19, 2018 - 13:34 NZST
This incident affected: MyCSP Portal (MyCSP Portal).