Microsoft Storage Explorer, timeouts to Azure Stack Hub's endpoints
Incident Report for Pax8
Resolved
Microsoft to release the official fix with its next iteration in Storage Explorer
Posted Aug 25, 2020 - 14:37 NZST
Update
We are continuing to work on a fix for this issue.
Posted Jul 14, 2020 - 12:49 NZST
Update
We are continuing to work on a fix for this issue.
Posted Jul 14, 2020 - 12:48 NZST
Identified
The problem has been identified in Storage Explorer and that node.js cert data ships with a reference to this expired root cert that takes-effect regardless of trying to supply a new one.
This was reported to node.js and fixed recently: https://github.com/nodejs/node/issues/33681
However, this will require Microsoft to ship an updated version of storage explorer with the updated node/electron references.
In the meantime we are working on a workaround until MS ships the updated version of Storage explorer out.
Posted Jul 02, 2020 - 15:20 NZST
Investigating
We are currently experiencing timeouts to Azure Stack Hub's endpoints using Microsoft Storage Explorer, we are aware of this issue and working with Microsoft towards a resolution.
Posted Jun 30, 2020 - 09:53 NZST
This incident affected: MyCSP Cloud - Powered by Azure Stack (NZ North, Management API).